System Requirements

System requirements

Below you will find the system requirements that guarantee trouble-free operation of our software. If you have any questions about installation or compatibility, our customer service and sales team will be happy to advise you.

If you are not confident enough to install our software yourself, we will be happy to do it for you. The installation is carried out by our experts on site or via remote maintenance. So nothing stands in the way of using BaSYS. Please contact our sales colleagues. We would be happy to send you a non-binding and individual offer for the installation service.

The following requirements apply to the client (local computer).

Note: The hardware requirements refer exclusively to BaSYS. If additional programs (e.g. CAD / GIS / DBMS) are installed on the client, the hardware requirements of the respective manufacturer must also be taken into account.

component
Minimum requirement
Recommended requirement
Processor:
Quad core
Quad Core or higher
Random access memory:
8GB RAM
16GB RAM
Hard disk:
5GB available
10GB or more available
Drive:
DVD
DVD
Network:
100 Mbps
1,000 Mbps
 
(Fast Ethernet)
(Gigabit Ethernet)
Graphic card:
1GB video memory
2GB video memory
 
(DirectX 9 compatible)
 
Monitor:
1920×1080 Full HD
Full HD or higher

 

Server Hardware – Recommended Requirements:

The recommended dimensioning of the server depends on the number of users available, the size of the data volume and the database management system to be used. To do this, check the respective system requirements of the database management system you are using. The storage space required for data storage by BaSYS can range from less than 0.5 GB for small projects to several 100 GB or more for large cities with several project variants and calculation runs.

The following requirements apply to BaSYS Web:

component
Minimum requirement
Processor:
Quad Core or higher
Random access memory:
12GB RAM or higher
Hard disk:
10GB or more available
Network:
1,000 Mbit/s (Gigabit Ethernet)

Note: Depending on the number of accesses, it may be necessary to upgrade the RAM.

The following requirements apply to the mobile device:

component
Minimum requirement
Recommended requirement
Processor:
Dual Core
Quad Core or higher
Random access memory:
4GB RAM
8GB RAM or higher
Hard disk:
Shock-mounted HDD
2 GB available
Shock-mounted SSD
5GB or more available
Network:
LAN/WLAN
Display:
10.1″ with XGA resolution (1024×768)
14.0″ with Full HD resolution
(1920×1080)
 
 
Touchscreen with pen operation
suitable for field service
Battery pack:
Running time 7 hours
Runtime 16 hours
Battery change during operation
GPS:
Via USB or serial interface (no PCIe)
  • Symbol explanation:
    ×    =    System/software is supported
       =    System/software is not supported
    1)    =    System/software is supported with limitations

     

    Operating systems (64 bit) *


    BaSYS version 9.24.1
    MS Windows 11 Enterprise/Pro
    ×
    MS Windows 10 Enterprise/Pro
    1)
    MS Windows 8.1 Enterprise/Pro
    ×
    MS Windows 8.0 Enterprise/Pro
    MS Windows 7 Pro/Ultimate/EP SP1
    ×
    MS Windows 7 Home/Vista/XP

    1) Minimum requirement: Windows 10 1607 (Anniversary Update) or newer.

    * Since BaSYS version 9.1, Microsoft .NET Framework 4.7.1 is required and installed automatically. Therefore, the following operating systems are no longer supported: Windows XP, Windows Vista, Windows 7 without SP, Windows 8.0, Windows 10 from 2015.

     

    Database management systems (64/32 bit)


    BaSYS version
    9.24.1
    MS SQL Server 2022
    ×
    MS SQL Server 2019
    ×
    MS SQL Server 2017
    ×
    Oracle Database 19c
    ×
    Oracle Database 18c
    ×
    Oracle Express
    PostgreSQL 16
    1)
    PostgreSQL 15
    1)
    PostgreSQL 14
    1)
    PostgreSQL 13
    1)
    PostgreSQL 12
    1)

    1) The following BaSYS modules are NOT supported under PostgreSQL

    • Structural condition assessment according to ISYBAU 0196 and 0601
    • Hydraulic condition assessment according to ISYBAU 0196
    • Structural condition assessment according to DWA M 149
    • ISYBAU Export 0196 / 0601

    The GIS surfaces GeoMedia and AutoCAD Map (FDO mode) are currently not supported under PostgreSQL.

     

    CAD (64 bit)


    BaSYS version
    9.24.1
    Autodesk AutoCAD Map 3D – 2024
    ×
    Autodesk AutoCAD Map 3D – 2023
    ×
    Autodesk AutoCAD Map 3D – 2022
    ×
    Autodesk AutoCAD Map 3D – 2021
    ×
    Bricsys BricsCAD V23 – Pro
    ×
    Bricsys BricsCAD V22 – Pro
    ×
    Bricsys BricsCAD V21 – Pro
    ×
    Bentley Microstation Connect Edition
    ×

     

    CAD (32 bit)


    BaSYS version
    9.24.1
    Autodesk AutoCAD Map 3D – 2024
    ×
    Autodesk AutoCAD Map 3D – 2023
    ×
    Autodesk AutoCAD Map 3D – 2022
    ×
    Autodesk AutoCAD Map 3D – 2021
    ×
    Bricsys BricsCAD V23 – Pro
    ×
    Bricsys BricsCAD V22 – Pro
    ×
    Bricsys BricsCAD V21 – Pro
    ×
    Bentley Microstation – V8i
    ×

     

    GIS (64 bit)


    BaSYS version
    9.24.1
    ESRI ArcGIS Pro – 3.2.x
    2)
    ESRI ArcGIS Pro – 3.1.x
    2)
    QGIS 3.34.x LTR
    1)
    QGIS 3.28.x LTR
    1)

    1) We recommend using the standalone installer setup for QGIS. If intermediate
    or developer versions of the open source software QGIS LTR (long
    term release versions) supported by BaSYS 9 exhibit instabilities, information can be obtained from the official
    QGIS website ( www.qgis.org ).

    2) Only released as an information station. ArcGIS Pro 3.x cannot run on SQL Server;
    Microsoft ODBC driver 18 ( can be downloaded here
    ) must first
    be installed.

     

    GIS (32 bit)


    BaSYS version
    9.24.1
    ESRI ArcGIS – 10.8.x
    5)
    ESRI ArcGIS – 10.7.x
    ×
    ESRI ArcGIS – 10.6.x
    4)
    ESRI ArcGIS – 10.5.x
    3) & 4)
    Intergraph Geomedia – 2020 Ess./Adv./Pro.
    ×
    Intergraph Geomedia – 2016 Ess./Adv./Pro.
    ×
    SynerGIS GeoOffice Analyst 10.8
    5)
    SynerGIS GeoOffice Analyst 10.7
    ×
    SynerGIS GeoOffice Analyst 10.6
    ×
    SynerGIS GeoOffice Analyst 10.5
    ×
    SynerGIS GeoOffice Express 10.8
    5)
    SynerGIS GeoOffice Express 10.7
    1)
    SynerGIS GeoOffice Express 10.6
    1)
    SynerGIS GeoOffice Express 10.5
    1)
    QGIS 3.34.x LTR
    2)
    QGIS 3.28.x LTR
    2)

    1) Only released as an information station.

    2) We recommend using the standalone installer setup for QGIS. If intermediate
    or developer versions of the open source software QGIS LTR (long
    term release versions) supported by BaSYS 9 exhibit instabilities, information can be obtained from the official
    QGIS website ( www.qgis.org ).

    3) ArcGIS 10.5 does not run on Oracle 12.2. To use Oracle 12.2, ArcGIS
    10.5.1 and this patch ( can
    be downloaded here
    ) must be installed.

    4) Not executable under Oracle 18c / 19c. To use Oracle 18c / 19c, ArcGIS 10.7
    or later must be installed.

    5) ArcGIS 10.8 / GeoOffice Analyst 10.8 / GeoOffice Express 10.8 cannot
    run under SQL Server; Microsoft ODBC driver 17 must first be installed ( can be downloaded here
    )
    .

     

    BIM (64 bit)


    BaSYS version
    9.24.1
    Autodesk Revit – 2024
    1)
    Autodesk Revit – 2023
    1)

    1) Only released as an information station.

     

    Network calculation software


    BaSYS version
    9.24.1
    STANET 8.4.41
    ×
    DHI MIKE 1D 2022
    ×

     

     

     

    Older version of the software matrix:

     

     

     

     

The BARTHAUER system diagnostic tool offers the possibility of providing various information to Barthauer customer service before or after installing BaSYS.

Version:
9.1
Date:
04/09/2018
zip file:

You can download the instructions for correctly installing and using the BARTHAUER system diagnostic tool as a  PDF here…